$re = '/<h[1-2].*?>(.*?)<\/h[1-2]>/m';
$str = '<h1>Hola</h1>asdasdasd
<h1>Test</h1>';
$subst = "<h2>$1</h2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;