using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('Your )(.*?)( were successfully )(<strong>edited<\/strong>\.')";
string substitution = @"L10n\:\:message\('action.label', array\('action' => L10n\:\:label\('edit'\), 'label' => L10n\:\:label\(MODULE\)\)\)";
string input = @"'Your package were successfully <strong>edited</strong>.'
'Your group were successfully <strong>edited</strong>.'
'Your subscriber were successfully <strong>edited</strong>.'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}