import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "('Your )(.*?)( were successfully )(<strong>edited<\\/strong>\\.')";
final String string = "'Your package were successfully <strong>edited</strong>.'\n"
+ "'Your group were successfully <strong>edited</strong>.'\n"
+ "'Your subscriber were successfully <strong>edited</strong>.'";
final String subst = "L10n\\:\\:message\\('action.label', array\\('action' => L10n\\:\\:label\\('edit'\\), 'label' => L10n\\:\\:label\\(MODULE\\)\\)\\)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}