import re
regex = re.compile(r"('Your )(.*?)( were successfully )(<strong>edited<\/strong>\.')", flags=re.MULTILINE)
test_str = ("'Your package were successfully <strong>edited</strong>.'\n"
"'Your group were successfully <strong>edited</strong>.'\n"
"'Your subscriber were successfully <strong>edited</strong>.'")
subst = "L10n\\:\\:message\\('action.label', array\\('action' => L10n\\:\\:label\\('edit'\\), 'label' => L10n\\:\\:label\\(MODULE\\)\\)\\)"
result = regex.sub(subst, test_str)
if result:
print(result)