use strict;
my $str = '\'Your package were successfully <strong>edited</strong>.\'
\'Your group were successfully <strong>edited</strong>.\'
\'Your subscriber were successfully <strong>edited</strong>.\'';
my $regex = qr/('Your )(.*?)( were successfully )(<strong>edited<\/strong>\.')/mp;
my $subst = 'L10n\\:\\:message\\(\'action.label\', array\\(\'action\' => L10n\\:\\:label\\(\'edit\'\\), \'label\' => L10n\\:\\:label\\(MODULE\\)\\)\\)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";