re = /('Your )(.*?)( were successfully )(<strong>edited<\/strong>\.')/m
str = '\'Your package were successfully <strong>edited</strong>.\'
\'Your group were successfully <strong>edited</strong>.\'
\'Your subscriber were successfully <strong>edited</strong>.\''
subst = 'L10n\\:\\:message\\(\'action.label\', array\\(\'action\' => L10n\\:\\:label\\(\'edit\'\\), \'label\' => L10n\\:\\:label\\(MODULE\\)\\)\\)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result