# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/src='([^']+)'\stext='([^']+)'\ssize=(\d+)/$1\n$2\n$3 /g;t' <<< "src='http://...' text='HELLO WORLD! More content' size=55"