$re = '/src=\'([^\']+)\'\stext=\'([^\']+)\'\ssize=(\d+)/';
$str = 'src=\'http://...\' text=\'HELLO WORLD! More content\' size=55';
$subst = "$1\n$2\n$3 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;