import Foundation
let pattern = #"src='([^']+)'\stext='([^']+)'\ssize=(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"src='http://...' text='HELLO WORLD! More content' size=55"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n$2\n$3 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)