use strict;
my $str = 'src=\'http://...\' text=\'HELLO WORLD! More content\' size=55';
my $regex = qr/src='([^']+)'\stext='([^']+)'\ssize=(\d+)/p;
my $subst = '$1\\n$2\\n$3 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";