const regex = /src='([^']+)'\stext='([^']+)'\ssize=(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src=\'([^\']+)\'\\stext=\'([^\']+)\'\\ssize=(\\d+)', 'g')
const str = `src='http://...' text='HELLO WORLD! More content' size=55`;
const subst = `$1\n$2\n$3 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);