package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`src='([^']+)'\stext='([^']+)'\ssize=(\d+)`)
var str = `src='http://...' text='HELLO WORLD! More content' size=55`
var substitution = "$1\n$2\n$3 "
fmt.Println(re.ReplaceAllString(str, substitution))
}