import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src='([^']+)'\\stext='([^']+)'\\ssize=(\\d+)";
final String string = "src='http://...' text='HELLO WORLD! More content' size=55";
final String subst = "$1\\n$2\\n$3 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}