// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"src='([^']+)'\stext='([^']+)'\ssize=(\d+)").unwrap();
let string = "src='http://...' text='HELLO WORLD! More content' size=55";
let substitution = "$1\\n$2\\n$3 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}