# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(LL?P)\s*,|,\s*(LL?P)$/ \1\2 /gm;t' <<< "LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
"