// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(LL?P)\s*,|,\s*(LL?P)$").unwrap();
let string = "LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
";
let substitution = " \\1\\2 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}