import Foundation
let pattern = #"^(LL?P)\s*,|,\s*(LL?P)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1\2 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)