#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(LL?P)\s*,|,\s*(LL?P)$"
Local $sString = "LP, bar, company LLP, foo, LLP" & @CRLF & _
"LLP, bar, company LLP, foo, LP" & @CRLF & _
"LLP,bar, company LLP, foo,LP" & @CRLF & _
""
Local $sSubst = " \1\2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)