const regex = new RegExp('^(LL?P)\\s*,|,\\s*(LL?P)$', 'gm')
const str = `LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
`;
const subst = ` \1\2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);