import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(LL?P)\\s*,|,\\s*(LL?P)$";
final String string = "LP, bar, company LLP, foo, LLP\n"
+ "LLP, bar, company LLP, foo, LP\n"
+ "LLP,bar, company LLP, foo,LP\n";
final String subst = " \\1\\2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}