using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(LL?P)\s*,|,\s*(LL?P)$";
string substitution = @" \1\2 ";
string input = @"LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}