use strict;
my $str = 'LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
';
my $regex = qr/^(LL?P)\s*,|,\s*(LL?P)$/mp;
my $subst = ' \\1\\2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";