package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(LL?P)\s*,|,\s*(LL?P)$`)
var str = `LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
`
var substitution = " \1\2 "
fmt.Println(re.ReplaceAllString(str, substitution))
}