$re = '/^(LL?P)\s*,|,\s*(LL?P)$/m';
$str = 'LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
';
$subst = " \1\2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;