re = /^(LL?P)\s*,|,\s*(LL?P)$/m
str = 'LP, bar, company LLP, foo, LLP
LLP, bar, company LLP, foo, LP
LLP,bar, company LLP, foo,LP
'
subst = ' \\1\\2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result