# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)^.{0,1000}DELETE ME(?-s).*\R?//gm;t' <<< "unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest."