// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)^.{0,1000}DELETE ME(?-s).*\R?").unwrap();
let string = "unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}