using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)^.{0,1000}DELETE ME(?-s).*\R?";
string substitution = @"";
string input = @"unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}