package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)^.{0,1000}DELETE ME(?-s).*\R?`)
var str = `unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}