re = /(?s)^.{0,1000}DELETE ME(?-s).*\R?/m
str = 'unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result