import re
regex = re.compile(r"(?s)^.{0,1000}DELETE ME(?-s).*\R?", flags=re.MULTILINE)
test_str = ("unnecessary stuff\n"
"unnecessary stuff\n"
"DELETE ME and some more stuff\n"
"This line should be the beginning\n"
"the rest.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)