const regex = /(?s)^.{0,1000}DELETE ME(?-s).*\R?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)^.{0,1000}DELETE ME(?-s).*\\R?', 'gm')
const str = `unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);