use strict;
my $str = 'unnecessary stuff
unnecessary stuff
DELETE ME and some more stuff
This line should be the beginning
the rest.';
my $regex = qr/(?s)^.{0,1000}DELETE ME(?-s).*\R?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";