import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^.{0,1000}DELETE ME(?-s).*\\R?";
final String string = "unnecessary stuff\n"
+ "unnecessary stuff\n"
+ "DELETE ME and some more stuff\n"
+ "This line should be the beginning\n"
+ "the rest.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}