#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)^.{0,1000}DELETE ME(?-s).*\R?"
Local $sString = "unnecessary stuff" & @CRLF & _
"unnecessary stuff" & @CRLF & _
"DELETE ME and some more stuff" & @CRLF & _
"This line should be the beginning" & @CRLF & _
"the rest."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)