# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m-s)^.*<div class="info">(?:.*\n){5}//g;t' <<< " <div>
<div class=\"info\">
line1
line2
line3
line4
line5
line6
"