const regex = /(?m-s)^.*<div class="info">(?:.*\n){5}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m-s)^.*<div class="info">(?:.*\\n){5}', 'g')
const str = ` <div>
<div class="info">
line1
line2
line3
line4
line5
line6
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);