use strict;
my $str = ' <div>
<div class="info">
line1
line2
line3
line4
line5
line6
';
my $regex = qr/(?m-s)^.*<div class="info">(?:.*\n){5}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";