// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m-s)^.*<div class="info">(?:.*\n){5}"#).unwrap();
let string = " <div>
<div class=\"info\">
line1
line2
line3
line4
line5
line6
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}