import Foundation
let pattern = #"(?m-s)^.*<div class="info">(?:.*\n){5}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div>
<div class="info">
line1
line2
line3
line4
line5
line6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)