# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m-s)^.*<div class=\"info\">(?:.*\n){5}"
test_str = (" <div>\n"
" <div class=\"info\">\n"
" line1\n"
" line2\n"
" line3\n"
" line4\n"
" line5\n"
" line6\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.