re = /(?m-s)^.*<div class="info">(?:.*\n){5}/
str = ' <div>
<div class="info">
line1
line2
line3
line4
line5
line6
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result