import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m-s)^.*<div class=\"info\">(?:.*\\n){5}";
final String string = " <div>\n"
+ " <div class=\"info\">\n"
+ " line1\n"
+ " line2\n"
+ " line3\n"
+ " line4\n"
+ " line5\n"
+ " line6\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}