using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m-s)^.*<div class=""info"">(?:.*\n){5}";
string substitution = @"";
string input = @" <div>
<div class=""info"">
line1
line2
line3
line4
line5
line6
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}