#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)[^\d\p{L}.,\s]+"
Local $sString = "L'élève s'est cassé la figure!" & @CRLF & _
"Il faut appeler le numéro 118 en cas d'accident." & @CRLF & _
"#drop-some-chars"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)