import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"[^\d\p{L}.,\s]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
L'élève s'est cassé la figure!
Il faut appeler le numéro 118 en cas d'accident.
#drop-some-chars
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)