re = /[^\d\p{L}.,\s]+/
str = 'L\'élève s\'est cassé la figure!
Il faut appeler le numéro 118 en cas d\'accident.
#drop-some-chars'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result