const regex = /[^\d\p{L}.,\s]+/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\d\\p{L}.,\\s]+', 'ug')
const str = `L'élève s'est cassé la figure!
Il faut appeler le numéro 118 en cas d'accident.
#drop-some-chars`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);