// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[^\d\p{L}.,\s]+").unwrap();
let string = "L'élève s'est cassé la figure!
Il faut appeler le numéro 118 en cas d'accident.
#drop-some-chars";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}