import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\d\\p{L}.,\\s]+";
final String string = "L'élève s'est cassé la figure!\n"
+ "Il faut appeler le numéro 118 en cas d'accident.\n"
+ "#drop-some-chars";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}